Cash App

Intermittent Login Issues
Incident Report for Cash App
Resolved
The service is up and running smoothly.
Posted Feb 23, 2020 - 07:12 PST
Identified
Our team has identified the issue preventing some customers from logging into Cash App from the mobile app and are working on a fix.

In the meantime, if you can't login on your phone, we recommend logging into your account via web browser at: https://cash.app/

We'll share any updates here.
Posted Feb 22, 2020 - 14:46 PST
Investigating
We're aware of an issue preventing some customers from successfully logging into their Cash App and are currently investigating. In the meantime, we recommend logging into your account via web browser at cash.app if you're experiencing this error.

We'll continue to share updates from here.
Posted Feb 22, 2020 - 10:51 PST
This incident affected: Send & Receive Money, Cash App Card, Cash Out, Bitcoin, and Settings.