Cash App

Bitcoin Deposits Delayed
Incident Report for Cash App
Resolved
This incident has been resolved.
Posted Sep 24, 2020 - 16:53 PDT
Investigating
We're aware of some customers experiencing delays with Bitcoin deposits and are currently investigating. We will be back with an update soon. Thank you for your patience.
Posted Sep 24, 2020 - 16:11 PDT
This incident affected: Bitcoin.