Cash App

Connection Issues
Incident Report for Cash App
Resolved
Today's connection issues have been fully resolved. To check the status of your transactions, please view your transaction activity. If your transaction is still pending, please pull down on the screen to refresh.

Thank you for your patience as we worked to resolve this.
Posted Jun 17, 2021 - 11:39 PDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 17, 2021 - 11:37 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 17, 2021 - 10:45 PDT
This incident affected: Send & Receive Money, Add Cash, Cash Out, Investing, and Settings.