Cash App

Intermittent Connection Issues
Incident Report for Cash App
Resolved
Today's connection issues have been fully resolved and all Cash App services are functioning as expected.

To view the status of your payment or transaction, please view your transaction activity. If your payment is still pending, please pull down to refresh and send.

Thank you again for your patience as we worked to resolve this issue.
Posted May 28, 2020 - 18:16 PDT
Update
A fix for today's connection issues is in place and we're working through a backlog of pending payments. If your payment is still pending, please do not retry at this time - it will be sent automatically.

Cash Card transactions are working as expected - if your Cash Card transaction was declined, you may now try again.

We'll be back with a final update once the issue has been fully resolved. Thank you again for your continued patience.

Brokerage services by Cash App Investing LLC, member FINRA / SIPC. Investing involves risk; you may lose money.
Posted May 28, 2020 - 15:53 PDT
Update
We're still experiencing connection issues impacting many Cash App services including Peer-to-Peer payments, Bitcoin, and Investing. If your Peer-to-Peer payment is pending, please do not re-attempt - it will be completed once the issue is resolved.

Cash Card transactions are now working as expected - if your Cash Card transaction was declined, please try again at this time.

We're continuing to work on a solution, and will return with another update as soon as possible.

Brokerage services by Cash App Investing LLC, member FINRA / SIPC. Investing involves risk; you may lose money.
Posted May 28, 2020 - 13:24 PDT
Identified
We've identified the root cause of the connection issues impacting all Cash App services including Peer-to-Peer payments, Cash Card transactions, Bitcoin, and Investing. We're actively working on a solution.

If your payment is pending, please do not re-attempt at this time.

We'll return with another update shortly - thank you for your patience.

Brokerage services by Cash App Investing LLC, member FINRA / SIPC. Investing involves risk; you may lose money.
Posted May 28, 2020 - 12:23 PDT
Investigating
We're investigating reports of connection issues impacting all Cash App services including Peer-to-Peer payments, Cash Card transactions, Bitcoin, and Investing.

If your payment is pending, please do not re-attempt at this time.

We'll be back with an update soon.

Brokerage services by Cash App Investing LLC, member FINRA / SIPC. Investing involves risk; you may lose money.
Posted May 28, 2020 - 10:53 PDT
This incident affected: Send & Receive Money, Cash App Card, Offers, Add Cash, Cash Out, Investing, Bitcoin, and Settings.