Cash App

Connection Issues
Incident Report for Cash App
Resolved
Today's connection issues have been fully resolved. To check the status of your payment, please view your transaction activity. If your payment is still pending, please pull down on the screen to refresh and send.

Thanks again for your patience as we worked to resolve this issue.
Posted Jun 14, 2021 - 20:44 PDT
Monitoring
A fix has been implemented and we're currently monitoring results for the connection issues customers are experiencing.

We'll return with another update once this issue has been fully resolved and things are caught up.
Posted Jun 14, 2021 - 17:47 PDT
Investigating
We're aware of some connection issues and are investigating. If your payment is pending, please do not reattempt it at this time. We'll be back with an update as soon as possible.
Posted Jun 14, 2021 - 17:09 PDT
This incident affected: Send & Receive Money, Cash App Card, Direct Deposit, Mobile Check Deposit, Offers, Add Cash, Cash Out, Investing, Borrow, Bitcoin, Settings, Support, and In-App Alert.