Cash App

Connection Issues
Incident Report for Cash App
Resolved
Today's connection issues have been fully resolved. To check the status of your payment, please view your transaction activity. If your payment is still pending, please pull down on the screen to refresh.

Thank you for your patience as we worked to resolve this.
Posted Jun 10, 2021 - 23:21 PDT
Identified
We're continuing to work on a resolution for customers experiencing connection issues today. If you have a pending payment, please do not reattempt it at this time.

We'll return with another update as soon as we more to share.
Posted Jun 10, 2021 - 23:18 PDT
Investigating
We're aware of some connection issues and are investigating. If your payment is pending, please do not reattempt it at this time.

We'll be back with an update shortly.
Posted Jun 10, 2021 - 22:50 PDT
This incident affected: Send & Receive Money, Cash App Card, Direct Deposit, Mobile Check Deposit, Offers, Add Cash, Cash Out, Investing, Borrow, Bitcoin, Settings, Support, and In-App Alert.