Cash App

Stored Balance Delays
Incident Report for Cash App
Resolved
This incident has been resolved.
Posted Feb 15, 2020 - 05:51 PST
Identified
Our team is aware of delays impacting updates to stored balances, including Bitcoin deposits. We've identified the issue and your balance should update shortly. Thank you for your patience.
Posted Feb 14, 2020 - 17:33 PST
This incident affected: Cash App Card and Bitcoin.