Cash App

Issues with Cash Boosts
Incident Report for Cash App
Resolved
This incident has been resolved.
Posted May 23, 2020 - 17:09 PDT
Update
We are continuing to investigate this issue.
Posted May 23, 2020 - 17:07 PDT
Investigating
We're experiencing some issues with Boosts right now, but we're working on a fix. Check back here for further updates.
Posted May 23, 2020 - 13:56 PDT
This incident affected: Offers.