Cash App

Delayed Payments
Incident Report for Cash App
Resolved
We were able to fix the issue delaying payments. All payments have been completed, and going forward they should behave normally. Thank you for bearing with us.
Posted 3 months ago. May 02, 2019 - 23:23 UTC
Investigating
We're investigating reports of delayed payments and are working quickly on a solution. Your payment will be completed shortly. Thank you for your patience.
Posted 3 months ago. May 02, 2019 - 22:16 UTC
This incident affected: Send & Receive Money.