Cash App

Pending Paper Money Deposits
Incident Report for Cash App
Resolved
We have resolved the issue around Paper Money Deposits.
Posted Mar 23, 2023 - 10:04 PDT
Investigating
We're aware of an issue causing pending Paper Money Deposits. We're investigating, and will be back with updates as soon as more info is available.
Posted Mar 23, 2023 - 07:50 PDT
This incident affected: Add Cash.