Cash App

Locked Boost Issues
Incident Report for Cash App
Resolved
Our team has resolved the issue with Locked Boosts being delayed. Thank you for your patience.
Posted Feb 14, 2020 - 15:49 PST
Investigating
We're looking into issues that are causing the delays in progress for Locked Boosts. We appreciate your patience!
Posted Feb 14, 2020 - 12:04 PST
This incident affected: Offers.