Cash App

Cash Performance Issues
Incident Report for Cash App
Resolved
This incident has been resolved.
Posted Oct 19, 2020 - 12:35 PDT
Monitoring
We're still experiencing issues with Investing and Bitcoin orders, and Add Cash and Cash Out's, and are continuing to work on a resolution. If your payment is pending, please do not re-try at this time. We'll return with another update as soon as possible.


Brokerage services by Cash App Investing LLC, member FINRA / SIPC. Investing involves risk; you may lose money.
Posted Oct 19, 2020 - 11:52 PDT
Investigating
We’re currently looking into an issue with Cash App Investing orders, Bitcoin orders, and Add Cash and Cash Out's. Please check back here for updates.

Brokerage services by Cash App Investing LLC, member FINRA / SIPC. Investing involves risk; you may lose money.
Posted Oct 19, 2020 - 10:45 PDT
This incident affected: Add Cash, Cash Out, Investing, and Bitcoin.