Cash App

Connection Issues
Incident Report for Cash App
Resolved
This incident has been resolved.
Posted Nov 13, 2019 - 08:15 PST
Investigating
Our team is investigating connectivity issues within the app. Check back for the latest updates.
Posted Nov 13, 2019 - 07:31 PST
This incident affected: Send & Receive Money, Cash App Card, Add Cash, Cash Out, Investing, and Bitcoin.