Cash App

Cash Investing Connection Issues
Incident Report for Cash App
Resolved
The issues with Cash App Investing has been resolved - thank you for your patience.

Brokerage services by Cash App Investing LLC, member FINRA / SIPC. Investing involves risk; you may lose money.
Posted Oct 05, 2020 - 18:58 UTC
Investigating
We’re currently investigating reports of technical issues impacting Cash App Investing.

If your trade is pending, please do not reattempt it at this time. If you need assistance selling your stock, please reach out directly to our carrying firm, DriveWealth LLC for further assistance. They can be reached at 1-800-461-2680. We’ll be back with an update shortly. Please note, DriveWealth LLC will not be able to assist with new purchases of stock at this time.

Brokerage services by Cash App Investing LLC, member of FINRA / SIPC. Investing involves risk; you may lose money.
Posted Oct 05, 2020 - 16:50 UTC
Monitoring
We're currently looking into an issue with Cash App Investing. Some sell orders may be delayed for a short period of time. Please check back here for updates.

Brokerage services by Cash App Investing LLC, member FINRA / SIPC. Investing involves risk; you may lose money.
Posted Oct 05, 2020 - 15:59 UTC
This incident affected: Investing.