Cash App

Intermittent Connection Issues
Incident Report for Cash App
Resolved
This incident has been resolved.
Posted Jun 02, 2020 - 07:45 PDT
Update
We are continuing to investigate this issue.
Posted Jun 02, 2020 - 07:43 PDT
Investigating
Some customers may be experiencing connection issues - we are currently investigating. If your payment is pending, please do not re-attempt at this time.

We'll be back with an update soon - thank you for your patience.
Posted Jun 01, 2020 - 16:14 PDT
This incident affected: Send & Receive Money.