Cash App

Cash Card Transactions
Incident Report for Cash App
Resolved
This incident has been resolved.
Posted 13 days ago. Apr 09, 2019 - 17:59 UTC
Investigating
10:40AM EST

We've identified an issue causing a small number of transactions to be incorrectly processed. We are actively working on a fix, and your balance will automatically be returned to normal shortly.
Posted 13 days ago. Apr 09, 2019 - 14:42 UTC
This incident affected: Cash Card.