Cash App

Connection issues - Bitcoin
Incident Report for Cash App
Resolved
The team has implemented a fix for the issues depositing and withdrawing Bitcoin as well as the verification status being reset. Please reach out if issues persist.
Posted Jun 24, 2022 - 07:48 PDT
Investigating
The team is aware of the issues depositing and withdrawing Bitcoin as well as the verification status being reset.
Posted Jun 24, 2022 - 06:51 PDT
This incident affected: Bitcoin.