Cash App

Intermittent Connection Issues for Cash.App Website
Incident Report for Cash App
Resolved
The connection issues with Cash.App have been fully resolved. Thanks again for your patience as we worked to resolve this issue.
Posted Nov 30, 2020 - 11:02 PST
Update
We are continuing to investigate this issue.
Posted Nov 30, 2020 - 11:01 PST
Investigating
We're currently experiencing connection issues with Cash.App, and are investigating this now. While our team works to restore Cash.App, you can still access your account directly from https://cash.app/account

We'll be back with an update soon - thank you for your patience.
Posted Nov 30, 2020 - 10:36 PST