Cash App

UK Customers Unable to Close Accounts
Incident Report for Cash App
Resolved
We've resolved the issue preventing UK customers from closing their accounts. You may attempt to do so at this time. Thanks again for your patience while our team worked to fix this.
Posted Nov 18, 2021 - 18:47 PST
Investigating
We are currently investigating an issue that's preventing UK customers from closing their accounts. When we have new information, we will share updates here. Thank you for your patience while we work to get this resolved.
Posted Nov 18, 2021 - 17:46 PST
This incident affected: Settings.