Cash App

Issues Updating Contact Information
Incident Report for Cash App
Resolved
Our team investigated and determined that customers contact information wasn't affected. Thanks for your patience while we looked into this.
Posted Jan 30, 2024 - 14:53 PST
Investigating
We’re currently investigating reports of issues with updating contact information. We appreciate your patience while we look into this. Check back here for ongoing updates.
Posted Jan 30, 2024 - 12:25 PST
This incident affected: Settings.