Cash App

Cash Card Issues at ARCO
Incident Report for Cash App
Resolved
Our team's resolved the Cash Card issues some customers were experiencing at ARCO gas stations and your card should now work as expected.
If you continue to have any issues with your Cash Card declining or double charging you at an ARCO gas station, please contact us in-app.
Posted Apr 13, 2021 - 08:13 PDT
Investigating
We’re aware of an issue with Cash Cards at ARCO gas stations. We're working to resolve this issue. We recommend utilizing an alternate payment method at this time.
Posted Apr 08, 2021 - 08:09 PDT
This incident affected: Cash App Card.