Cash App

Connection Issues
Incident Report for Cash App
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 17, 2024 - 17:00 PDT
Investigating
We’re investigating reports of connection issues impacting multiple Cash App features. Thanks for your patience as we work through this. We'll update you as soon as possible.
Posted Oct 17, 2024 - 16:41 PDT
This incident affects: Send & Receive Money, Cash App Card, Cash App Pay, Bitcoin, In-App Alert, Log In, and Deposit paper money.