Cash App

Cash Card Apple Pay verification not working

Incident Report for Cash App

Resolved

This incident has been resolved.
Posted May 19, 2023 - 14:30 PDT

Investigating

We're aware of the issue regarding Cash Card verification for Apple Pay. Our team is investigating this issue and will share updates as soon as possible.
Posted May 18, 2023 - 14:19 PDT
This incident affected: Settings and In-App Alert.