Cash App
Investing Delays
Incident Report for
Cash App
Update
We are continuing to investigate this issue.
Posted
Jan
28
,
2021
-
17:22
UTC
Investigating
We’re currently looking into an issue with Cash App Investing. Some orders may be delayed. Please check back here for updates.
Brokerage services by Cash App Investing LLC, member FINRA / SIPC. Investing involves risk; you may lose money.
Posted
Jan
28
,
2021
-
15:54
UTC
This incident affects: Investing.
×
Subscribe to Incident
Subscribe to updates for
Investing Delays
via . You'll receive .