Cash App
Connection Issues
Incident Report for
Cash App
Resolved
We've resolved the issue impacting multiple Cash App features. You may re-attempt any failed transactions at this time. Thank you for your patience.
Posted
Jul
03
,
2025
-
15:48
PDT
Identified
We’re aware of an issue impacting multiple features. Thanks for your patience in the meantime.
Posted
Jul
03
,
2025
-
15:19
PDT
Update
We’re aware of an issue impacting multiple features. Thanks for your patience in the meantime.
Posted
Jul
03
,
2025
-
13:10
PDT
Investigating
We’re aware of an issue impacting some payment and deposit features. Thanks for your patience in the meantime.
Posted
Jul
03
,
2025
-
12:02
PDT
This incident affected: Send & Receive Money, Cash App Pay, Direct Deposit, Mobile Check Deposit, Add Cash, In-App Alert, and Deposit paper money.
×
Subscribe to Incident
Subscribe to updates for
Connection Issues
via . You'll receive .