We've resolved the issue impacting Cash App Cards. If you experienced an error ordering a Cash App card, please retry any failed attempts. Thanks for your patience while we looked into this.
Posted Jul 21, 2026 - 15:05 PDT
Investigating
We're investigating reports of an issue with Cash App Cards and will share another update soon. Thanks for your patience in the meantime.
Posted Jul 21, 2026 - 13:49 PDT
This incident affected: Cash App Card and In-App Alert.