Cash App

Statement issue
Incident Report for Cash App
Resolved
We've resolved the issue impacting PDF statements. If you continue to experience any issues, please reach out to support.
Posted Jul 22, 2024 - 15:00 PDT
Investigating
We're investigating reports of an issue impacting statements and will share another update soon. Thanks for your patience in the meantime.
Posted Jul 22, 2024 - 14:08 PDT
This incident affected: Settings and In-App Alert.