The issue affecting round up transactions in Cash App Investing has been resolved. All previously pending transactions have now completed successfully. Thank you for your patience while our team investigated this issue.
Posted Mar 20, 2026 - 09:47 PDT
Investigating
We’re currently looking into an issue with Cash App Investing. Customers are experiencing longer than expected pending states for their round up transactions. Please check back here for updates.
Posted Mar 20, 2026 - 08:53 PDT
This incident affected: Investing and In-App Alert.