Cash App

Stocks Owned Issue
Incident Report for Cash App
Resolved
Thanks for your patience! We’ve resolved the issue with Cash App Investing.
Posted May 20, 2024 - 06:28 PDT
Monitoring
We’ve applied a fix for the issue with Cash App Investing. We'll provide a final update once we’ve confirmed that this is resolved.
Posted May 16, 2024 - 07:49 PDT
Update
We are continuing to investigate this issue.
Posted May 15, 2024 - 13:06 PDT
Investigating
We’re currently looking into an issue with Cash App Investing. You may experience issues when viewing your ‘Stocks Owned’ section. Please check back here for updates.
Posted May 14, 2024 - 10:02 PDT
This incident affected: Investing and In-App Alert.