Cash App

Cash App Taxes Issue

Incident Report for Cash App

Resolved

We've resolved the issue impacting Cash App Taxes. You can find support for general tax-related questions at taxeshelp.cash.app. Thanks for your patience.
Posted May 30, 2025 - 08:54 PDT

Investigating

We're investigating reports of an issue impacting Cash App Taxes and will share another update soon. Thanks for your patience in the meantime.
Posted May 30, 2025 - 08:48 PDT
This incident affected: In-App Alert and Cash App Taxes.