Cash App

Payment Issues
Incident Report for Cash App
Resolved
Cash App is back to 100% and all pending payments have been completed. Thank you for your patience today.
Posted Sep 12, 2023 - 16:30 PDT
Monitoring
We’ve applied a fix, however, some customers may continue to experience delayed payments. To confirm payment status, please check the Activity section in your Cash App. We'll provide a final update once everything is resolved.
Posted Sep 12, 2023 - 15:58 PDT
Investigating
We’re investigating reports of connection issues. Please do not re-attempt any pending payments. We'll update you as soon as possible.
Posted Sep 12, 2023 - 15:32 PDT
This incident affected: Send & Receive Money and In-App Alert.