Cash App

Connection Issues

Incident Report for Cash App

Resolved

We've fixed the connection issues impacting some of our features. Thanks for your patience while we worked to resolve this.
Posted Oct 22, 2025 - 16:23 PDT

Identified

We're investigating reports of connection issues impacting multiple Cash App features, and are working to resolve this quickly. Thanks for your patience while we look into this.
Posted Oct 22, 2025 - 16:13 PDT

Update

We're investigating reports of connection issues impacting multiple Cash App features, and are working to resolve this quickly. Thanks for your patience while we look into this.
Posted Oct 22, 2025 - 15:52 PDT

Investigating

We're investigating reports of connection issues impacting multiple Cash App features, and are working to resolve this quickly. Thanks for your patience while we look into this.
Posted Oct 22, 2025 - 15:45 PDT
This incident affected: Cash App Card, Investing, Bitcoin, In-App Alert, and Log In.