Cash App

Stock Delays
Incident Report for Cash App
Resolved
This incident has been resolved.
Posted Mar 18, 2020 - 14:07 PDT
Investigating
We’re looking into an issue with Cash App Investing right now. Some orders may be delayed. Please check back here for updates.


Brokerage services by Cash App Investing LLC, member FINRA / SIPC. Investing involves risk; you may lose money.
Posted Mar 18, 2020 - 07:34 PDT
This incident affected: Investing.