Cash App
P2P Pending Payments
Incident Report for
Cash App
Resolved
Cash App is back to 100% and all pending payments have been completed. Thank you for your patience.
Posted
Nov
13
,
2023
-
07:02
PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted
Nov
12
,
2023
-
18:38
PST
Investigating
We're investigating reports of connection issues that are causing pending payments. Please do not retry any payments at this time.
Posted
Nov
12
,
2023
-
18:23
PST
This incident affected: Send & Receive Money and In-App Alert.
×
Subscribe to Incident
Subscribe to updates for
P2P Pending Payments
via . You'll receive .