Cash App

Cash App Connection Issues
Incident Report for Cash App
Resolved
We've resolved the outage affecting multiple Cash App features. Thank you for your patience.
Posted Oct 15, 2024 - 17:58 PDT
Investigating
We're investigating reports of an outage impacting multiple Cash App features. Thanks for your patience while we look into this, we'll provide an update soon.
Posted Oct 15, 2024 - 17:38 PDT
This incident affected: In-App Alert.