Cash App
Check Deposit Issue
Incident Report for
Cash App
Resolved
We've resolved the issue impacting check deposits. All previously pending check deposits have been processed. Thank you for your patience.
Posted
Feb
24
,
2025
-
18:23
PST
Investigating
We're investigating reports of an issue with depositing checks and will share another update soon. Thanks for your patience in the meantime.
Posted
Feb
23
,
2025
-
19:28
PST
This incident affected: Mobile Check Deposit and In-App Alert.
×
Subscribe to Incident
Subscribe to updates for
Check Deposit Issue
via . You'll receive .