Cash App

Login Issues

Incident Report for Cash App

Resolved

We've resolved the issue impacting Cash App Cards and logins. You may re-attempt any actions that failed. Thank you for your patience.
Posted Oct 09, 2025 - 13:57 PDT

Monitoring

We've applied a resolution for the issues impacting Cash App Cards and logins, but some customers may still experience issues. We'll provide a update once we’ve confirmed the issue is fully resolved.
Posted Oct 09, 2025 - 13:15 PDT

Update

We're investigating reports of connection issues that are impacting login, account creation, and Cash App Card features. Thanks for your patience in the meantime.
Posted Oct 09, 2025 - 12:44 PDT

Investigating

We're investigating reports of login issues to Cash App and will share another update soon. Thanks for your patience in the meantime.
Posted Oct 09, 2025 - 12:42 PDT
This incident affected: Cash App Card, In-App Alert, and Log In.