Cash App

Payments stuck in Pending
Incident Report for Cash App
Resolved
This incident has been resolved.
Posted Jun 01, 2023 - 16:47 PDT
Monitoring
We have put a fix in place for the issue causing payments to other Cash App customers to pend. We will post any additional updates here. Thanks for your patience!
Posted Jun 01, 2023 - 16:13 PDT
This incident affected: Send & Receive Money and In-App Alert.