Cash App

Cash App Connection Issues

Incident Report for Cash App

Resolved

We've resolved the outage affecting multiple Cash App features. Thank you for your patience.
Posted Feb 26, 2025 - 14:57 PST

Monitoring

We've resolved most of the impacts to Cash App features. We're still monitoring some delays to adding cash and peer to peer payments and will continue to update here. Thank you for your patience.
Posted Feb 26, 2025 - 14:39 PST

Update

We are beginning to see recovery in the impacts to many Cash App features and are continuing to monitor as this issue is resolved. We'll continue to update here. Thanks for your patience.
Posted Feb 26, 2025 - 14:26 PST

Update

We are beginning to see recovery in the impacts to many Cash App features and are continuing to monitor as this issue is resolved. We'll continue to update here. Thanks for your patience.
Posted Feb 26, 2025 - 13:26 PST

Update

We're investigating reports of an outage impacting multiple Cash App features. Thanks for your patience, we'll provide an update soon.
Posted Feb 26, 2025 - 12:55 PST

Investigating

We're investigating reports of an outage impacting multiple Cash App features. Thanks for your patience, we'll provide an update soon.
Posted Feb 26, 2025 - 12:34 PST
This incident affected: Send & Receive Money, Add Cash, and In-App Alert.