Cash App

Connection Issues
Incident Report for Cash App
Resolved
Today's connection issues have been fully resolved and any pending payments should have processed accordingly. To check the status of your payment, please view your transaction activity. If your payment is still pending, please pull down on the screen to refresh.
Posted Jul 28, 2021 - 13:26 PDT
Investigating
We're experiencing connection issues, and are currently investigating. If your payment is pending, please do not re-attempt at this time.
Posted Jul 28, 2021 - 11:48 PDT
This incident affected: Send & Receive Money and In-App Alert.