Cash App

Intermittent Connection Issues
Incident Report for Cash App
Resolved
Today's connection issues regarding pending payments and delayed push notifications have been fully resolved.

To check the status of a payment, please review your transaction activity. If a payment is pending, please pull down within your activity feed tab to refresh. If you had a pending payment fail, you're welcome to retry sending it.

Thanks again for your patience while we worked to fix these issues.
Posted Jul 24, 2020 - 18:40 PDT
Investigating
Some customers may still be experiencing intermittent connection issues. We are continuing to work on a solution, but if your payment is pending, please do not re-try at this time.

We'll share an update once this issue is resolved.
Posted Jul 24, 2020 - 17:56 PDT
Update
Push notifications have caught up and should be arriving in real-time now.

We're still experiencing the connection issues causing pending payments and our team is diligently working on a solution.

Thanks for your patience while we get a fix in place. Updates will continue to be shared here.
Posted Jul 24, 2020 - 16:13 PDT
Identified
We're making progress on getting the connection issues that some customers are experiencing, fixed.

Affected customers may encounter pending payments or payments taking slightly longer to complete. Pending payments do not need to be re-sent at this time - they will automatically go through once a connection is made.

Some push notifications may still be delayed, but they should arrive shortly.

We'll be back with an update once we have more to share.
Posted Jul 24, 2020 - 15:06 PDT
Investigating
Our team's still working on a fix for the connection issues causing pending payments and delayed push notifications.

If you have a pending payment, it should be sent soon. At this time you do not need to retry it.

We'll continue to share updates here.
Posted Jul 24, 2020 - 13:52 PDT
Identified
Our team is aware some customers are experiencing connection issues causing payments to take a little longer to send, or go into a pending status.

If you have a pending payment, you do not need to resend it at this time. It should automatically send once a connection has been made.

We're also aware push notifications are slightly delayed. If you're expecting a notification, it should arrive shortly.

We'll be back with an update soon.
Posted Jul 24, 2020 - 13:06 PDT
This incident affected: Send & Receive Money and Settings.