Cash App

Scheduled Maintenance
Incident Report for Cash App
Resolved
Maintenance has been completed, and full functionality of the app has been restored. Thank you for your patience during this time.
Posted Jun 10, 2022 - 05:02 PDT
Investigating
Our team is performing some maintenance that may temporarily affect the functionality of the app. If any payments are pending, please do not reattempt them, as they will complete on their own. We appreciate your patience while we work to get the app back up and running smoothly.
Posted Jun 09, 2022 - 13:59 PDT
This incident affected: Send & Receive Money, Add Cash, and In-App Alert.