Cash App
Bitcoin withdrawals delayed
Incident Report for
Cash App
Resolved
Our team was able to get a fix in place for the delayed Bitcoin withdrawals and deposits. Thanks for your patience as we worked through this.
Posted
Apr
11
,
2024
-
17:51
PDT
Update
We are continuing to investigate this issue.
Posted
Apr
11
,
2024
-
16:45
PDT
Investigating
We are aware of an issue impacting Bitcoin withdrawals. We'll keep you updated as we look into this, thanks for your patience.
Posted
Apr
11
,
2024
-
16:40
PDT
This incident affected: Bitcoin.
×
Subscribe to Incident
Subscribe to updates for
Bitcoin withdrawals delayed
via . You'll receive .