Cash App

Connection Issues

Incident Report for Cash App

Resolved

We've resolved the issue impacting logins to Cash App and account creation for Android users. Feel free to retry all actions as they should now be successful but you may still experience some residual affects. Thank you for your patience while we investigated this.
Posted May 15, 2025 - 11:32 PDT

Update

We're investigating reports of connection issues impacting logins and account creation for Android users and are working to resolve this quickly. We apologize for any inconvenience this may have caused and appreciate your patience in the meantime.
Posted May 15, 2025 - 11:10 PDT

Investigating

We're investigating reports of connection issues impacting logins and account creation for Android users and are working to resolve this quickly. We apologize for any inconvenience this may have caused and appreciate your patience in the meantime.
Posted May 15, 2025 - 10:41 PDT
This incident affected: In-App Alert and Log In.