Cash App
Card Linking Failures
Incident Report for
Cash App
Resolved
This incident has been resolved.
Posted
Nov
14
,
2023
-
11:22
PST
Update
We are continuing to investigate this issue.
Posted
Nov
14
,
2023
-
11:21
PST
Update
We are continuing to investigate this issue.
Posted
Nov
14
,
2023
-
11:08
PST
Investigating
We are currently investigating this issue.
Posted
Nov
14
,
2023
-
11:07
PST
This incident affected: Add Cash and Settings.
×
Subscribe to Incident
Subscribe to updates for
Card Linking Failures
via . You'll receive .