Cash App

Customers unable to buy or sell stocks
Incident Report for Cash App
Resolved
The team has identified and resolved the issue causing some customers to be unable to buy or sell stocks. If the issue continues, please reach out.
Posted Aug 03, 2022 - 10:29 PDT
Update
The team has identified and resolved the issue causing some customers to be unable to buy or sell stocks. If the issue persists, please reach out.
Posted Aug 03, 2022 - 07:56 PDT
Investigating
We’re currently looking into an issue with Cash App Investing. Some customers may be unable to buy or sell stocks at this time. Please check back here for updates.
Posted Aug 03, 2022 - 07:13 PDT
This incident affected: Investing.