Cash App

Bitcoin Deposits and Withdrawals Delays
Incident Report for Cash App
Resolved
This incident has been resolved.
Posted May 10, 2020 - 00:27 UTC
Investigating
We are currently investigating this issue. Customers who made Bitcoin withdrawals and deposits from 9:40AM PST to 12:40PM PST May 8th, 2020 may experience delays.
Posted May 09, 2020 - 23:32 UTC
This incident affected: Bitcoin.