We've resolved the issue preventing some customers from using or viewing their Cash Card.
Thank you again for your patience as we worked to resolve this issue.
Posted Sep 15, 2023 - 08:23 PDT
Identified
We're aware of an issue causing some customers to not be able to use their Cash Card or see their Cash Card in-app. We are actively working on a fix. We'll return with an update as soon as we have more information - thank you for your patience.
Posted Sep 14, 2023 - 09:26 PDT
This incident affected: Cash Card and In-App Alert.