Cash App

Cash Card Issues
Incident Report for Cash App
Resolved
Our team has resolved the multiple features of the Cash Card including new card ordering, enabling/disabling, and Cash Card transactions. Thank you for your patience while our team worked on this. Your Cash Card will work normally moving forward.
Posted Mar 11, 2023 - 15:53 PST
Identified
We are currently investigating an issue affecting multiple features of the Cash Card including new card ordering, reporting Cash Cards lost/stolen, and enabling/disabling the Cash Card. At this time, Cash Card transactions are not affected.
Posted Mar 11, 2023 - 15:34 PST
Investigating
We are currently investigating an issue affecting multiple features of the Cash Card including new card ordering, enabling/disabling, and Cash Card transactions. If you've experienced a failed or delayed Cash Card transaction, please do not retry it at this time. We will update this page as more information becomes available. Thank you for your patience and understanding.
Posted Mar 11, 2023 - 14:50 PST
This incident affected: Cash App Card.