Cash App

Customers unable to download 1099-K tax forms from mobile app
Incident Report for Cash App
Resolved
This incident has been resolved. If you're still having issues, please reach out to us.
Posted Feb 01, 2023 - 12:36 PST
Investigating
We’re investigating an issue causing some customers to be unable to download 1099-K tax forms from their mobile app. 1099-K tax forms should still be available for download at cash.app. We'll update you as soon as possible.
Posted Jan 24, 2023 - 15:20 PST
This incident affected: Settings.